Perfectly Modded
Perfectly Modded

Modding done right!
 
HomeHome  WebsiteWebsite  FacebookFacebook  YouTubeYouTube  TwitchTwitch  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 [solved]failed to allocate memory

View previous topic View next topic Go down 
AuthorMessage
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: [solved]failed to allocate memory   Tue Dec 13, 2016 5:14 am

Hello, thank you for the awesome pack. I made it to lvl 4 - walked from Riften to Whiterun. As I approached Whiterun, started crashing. Got the "failed to allocate" memory error. Happens within seconds every time I load back up. I haven't altered anything in the pack. Followed install directions to drive X. Was working fine until Whiterun.

I have i7 6700
16 gb DDR
GTX 1070
SSD 250gb for Windows/1tb for games
MSI B150 M3 mobo

I have gone into enblocal and confirmed ReduceSystemMemoryUsage is set "true"

VideoMemorySizeMb was set to 20048, I set it to 8192 which should match the actual memory of my video card unless I'm mistaken.

I cannot find the crashfix.ini the error referenced.

Forgive me if I missed something. I'm 46, new to modding Skyrim, came back to Skyrim after years because I heard about this pack. Thanks in advance!
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Tue Dec 13, 2016 5:36 am

Hello it's probably related to a simple ENB setting.

You'll have to forgive me as i'm drunk AF.

See the guides @ http://perfectlymodded.weebly.com/ if they don't help, i'll try to help you out.

Cheers!

Rotten lullaby

__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Tue Dec 13, 2016 6:19 am

Looks like ram was set to high in enblocal. I ran the vramtest and set it to 4096 or whatever and things seem stable now. Thanks for the help and for the excellent pack!

[EDIT] annnd I spoke too soon. crashed as I was making my way out of whiterun city area. will continue to study the guides, but I didn't see much else I could do that was an easy fix, at any rate.

* I am using the prisoner pre-config save game from the optional folder

* In MO, I only have these 3 Mods unchecked in the left pane:
Rottens Custom Death Sounds
Rottens Lively Combat
MMMR2

Everything in the right pane is checked except:
dD - Larger Splatter Size

* My enblocal.ini

[PROXY]
EnableProxyLibrary=false
InitProxyFunctions=true
ProxyLibrary=d3d9AL.dll

[GLOBAL]
UsePatchSpeedhackWithoutGraphics=false
UseDefferedRendering=true
IgnoreCreationKit=true

[PERFORMANCE]
SpeedHack=true
EnableOcclusionCulling=true

[MULTIHEAD]
ForceVideoAdapterIndex=false
VideoAdapterIndex=0

[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=128
VideoMemorySizeMb=4064
EnableCompression=true
AutodetectVideoMemorySize=false

[WINDOW]
ForceBorderless=false
ForceBorderlessFullscreen=false

[ENGINE]
ForceAnisotropicFiltering=true
MaxAnisotropy=16
ForceLodBias=true
LodBias=-0.12
AddDisplaySuperSamplingResolutions=false
EnableVSync=false
VSyncSkipNumFrames=0

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=60.0

[INPUT]
//shift
KeyCombination=16
//f12
KeyUseEffect=123
//home 36 disabled 0
KeyFPSLimit=0
//num  106
KeyShowFPS=106
//print screen
KeyScreenshot=44
//enter
KeyEditor=17
//f4
KeyFreeVRAM=115
//Brute force disabled by default
KeyBruteForce=0

[ADAPTIVEQUALITY]
Enable=false
Quality=1
DesiredFPS=20.0

[ANTIALIASING]
EnableEdgeAA=true
EnableTemporalAA=false
EnableSubPixelAA=true

[FIX]
FixGameBugs=true
FixParallaxBugs=true
FixParallaxTerrain=false
FixAliasedTextures=true
IgnoreInventory=true
FixTintGamma=false
RemoveBlur=false
FixSubSurfaceScattering=true
FixSkyReflection=true
FixCursorVisibility=true
FixLag=false

[LONGEXPOSURE]
EnableLongExposureMode=false
Time=1.0
BlendMax=0.0
[THREADS]
DataSyncMode=0
PriorityMode=0
EnableUnsafeFixes=false

* Also, shots of my config (right click and open in new tab):
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Fri Dec 16, 2016 11:13 am

InitProxyFunctions=true
ProxyLibrary=d3d9AL.dll


this is not needed anymore ↑


InitProxyFunctions=false
ProxyLibrary=other.dll

Make sure you have admin rights/run as admin (in compatibility tab) when running the pack for the .exe that your are using

Modorganizer.exe
ENBhost.exe
TESV.exe

__________________________


Last edited by RottenDub on Sun Dec 18, 2016 10:08 am; edited 1 time in total
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sun Dec 18, 2016 3:25 am

Definitely more stable. No more memory errors for the moment or hard freezes that force me to sign out of Windows in order to close Skyrim.

Still kinda baffled that with my system specs I'm only getting 25 fps. And that's with UseDefferedRendering set to either true or false. I changed grass from 70 to 100, no change in fps there either. I'm wondering how accurate the built in fps monitor is. Though I'll admit it feels more like 25 than 60 fps to me. 

Despite everything, enjoying SPM bigtime and I have to confess I'm amazed at the amount of time and energy you've put into this. Kudos!
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Sun Dec 18, 2016 10:29 am

I recently found out that capping FPS with RivaTunerStatisticServer can lead to silky smooth movement in-game.


Enlarge this image


I recommend the method above because it produces very fluid frames VS any kind of other FPS limiter because it also smooths frame-timing.




I consider anti-lag dll and .cfg useless now because RTSS does it way better.

Strange with the 25 FPS though, i have a much weaker/older generation GPU and the pack runs fine with it.
Take a look to see if you didn't accidentally set V-sync adaptive(half refresh rate) in Nvidia CP

__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
Cheesypoofy
New Face!
New Face!


Posts : 2
Points : 122
Reputation : 0
Join date : 2016-10-23

PostSubject: Re: [solved]failed to allocate memory   Sun Dec 18, 2016 9:40 pm

Launch Skyrim Configurator through mod organizer (Icon looks like black silhouette of the dragonborn between FNIS and ENB Manager) and make sure all the use threading options are ticked.  You'll have to tick advanced at the bottom of the window to reveal these additional options.  There should be a total of 7 places under the texture and models/world(general & trees) you can tick to turn threading on to allow your cpu to use multiple cores. Let us know if/how much this helps since it varies depending on system specs.  Also resist messing with or cranking up the other settings unless you know what you're doing since it can do more harm than good.
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Mon Dec 19, 2016 6:24 am

Rotten: I did not see vsync adaptive set anywhere. I'm downloading Riva now, I'll give that a try. Thank you! I don't know if it matters that I am using G Sync?

Cheesy: none of the threaded options were checked. I found them all and checked them off. I'll report back once I see how things go.

What a supportive community! Thanks a ton :)
Back to top Go down
View user profile
Cheesypoofy
New Face!
New Face!


Posts : 2
Points : 122
Reputation : 0
Join date : 2016-10-23

PostSubject: Re: [solved]failed to allocate memory   Tue Dec 20, 2016 8:37 pm

G Sync will definitely give you issues with skyrim.  There are fixes you can find using google.  Just be aware some fixes apply only to the original skyrim which are what you want, some to the new special edition recently released, and some to both versions.
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Thu Dec 22, 2016 1:50 am

From what I can tell, running the RivaTuner takes care of the G Sync issue. I could be wrong though...

I'm still seeing 25 frames reported in game but there's no way that's accurate, it's running much smoother than that.
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Thu Dec 22, 2016 9:01 am

@Spookeh70 wrote:
From what I can tell, running the RivaTuner takes care of the G Sync issue. I could be wrong though...

I'm still seeing 25 frames reported in game but there's no way that's accurate, it's running much smoother than that.

If you have a 120Hz monitor you should have an option "adaptive vsync half refresh rate"

What monitor are you using for the onscreen FPS counter you can easily use the one from Nvidia Shadowplay or the one from MSI Afterburner for if you don't trust the one you have now.

__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Thu Dec 22, 2016 3:50 pm

I'll check the vsync half refresh setting tonight when I get home, thanks for the tip. I can turn off G Sync if I need to through the Nvidia control panel.

I did encounter some pretty heavy frame rate drops last night. I was in the woods outside of Falkreath and ran into a pretty good size hunting party - maybe 10-12 npcs. My frames bit the dust in a hurry. There were some ancient matron spriggans further out on screen as well. Still though, it boggles me that my rig would run into that kind of fps decrease at all. Up until then though, since I started running RivaTuner, things were going good.

I use the built in FPS monitor that comes with the pack - I just press * to use it.
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Thu Dec 22, 2016 5:02 pm

Try disableing G-Sync with the pack, Skyrim should only run at 60 anyway!

With that kind of PC you should only get 1-2 sec framerate drops in the 3 big towns (Whiterun / Solitude...???)

Also in combat and NPC's frame rate should only go down when 100+ active NPCs are fighting or fighting you




__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Thu Dec 22, 2016 11:44 pm

Iv been having performance issues as well i normally get 60 fps constant at 2k running a gtx 1080 and i7-6700k but for some reason i get random dips to about 10-12 fps and sometimes it just freezes completely for a second and i cant for the life of me figure out why its doing that i turned off g-sync already and have the game limited to 60 fps but the drops still occur
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 3:39 am

Rotten - so I set up Nvidia Shadowplay...found it interesting that as soon as I loaded up the game the FPS counter showed up in the corner and was at 24 FPS and I didn't even load up the game save yet. The FPS limiter setting seems to be off in my enblocal.ini. What else could be set to limit it? RivaTuner is set for 55 per your instructions.
[EDIT{] Confirmed that in game with the Nvidia FPS counter, FPS is still stuck at 25. 

[LIMITER]
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=60.0


Last edited by Spookeh70 on Sat Dec 24, 2016 5:41 am; edited 1 time in total
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 3:55 am

the menu that loads up before you start a game is locked to 30 fps so its normal t get 25-30 before starting a game i also use Rivia tuner to limit my fps but my main menu is still at 30 fps. Also i highly recommend turning off shadow play as it was causing my game to crash a lot and you really only need/want 1 fps limiter or u can get some tearing. Personally i use Rivia tuner as it smooths the fps better than any of the others and then i turn off all other things limiting the fps
Back to top Go down
View user profile
RottenDub
Admin
Admin


Posts : 1429
Points : 2604
Reputation : 286
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 4:58 am

•When the game starts up you should see 30 FPS
•When the main menu fully loads and you can move cursor load game etc it should be to whatever you set your limiter to (55-60)
•Loading screens are 30 FPS in Skyrim
•Ingame 45-55-60 (limiter)

*Here are my settings for rivatuner



*Don't forget to add TESV.exe in there.

*Check Nvidia Control panel and see your v-sync options for TESV.exe (you might need to add it)


__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 5:55 am

gsync off
vsync on
RivaTuner settings identical to yours with TESV added in the list of programs

no matter what, I remain locked at 24 FPS. I'd let you remote in if I knew how :P
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 6:27 am

This might sound dumb but if its at 24 fps then it may be your monitor. When you right click ur desktop go to Nvidia control panel then change resolution and there will be a drop down for the monitor refresh rate. if that is set to 24 hz and u have v sycn on the game will go to a max of 24 fps. prob not the problem but just a thought since its exactly 24 fps and that happens to be a refresh rate on monitors.
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 6:41 am

That was it right there! 55 frames with RiveTuner! However, side effect is I now have to decide if I want 24 FPS or screen tearing...

[EDIT] I seem to be having success with gsync off and vsync set to fast. Getting 47 FPS and little to no tearing.
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 7:28 am

if you are using rivia tuner i would highly recommend turning v-sync off in the Nividia control panel its literally pointless since rivia tuner is doing the exact same thing but better. Worth a try at least

edit: also if u turn v-sycn off and leave rivia tuner at 60 fps then u can lower ur refresh rate back to 24 hz however even if u get 50-60 fps since ur monitor is only 24 hz you can only ever see 24 fps
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 5:06 pm

was getting tearing with vsync off and rivatuner on. getting decent frames with vsync on fast. I still don't completely understand that. I also have adaptive and half-adaptive so I'll experiment.

weird side effect of turning vsync to any other setting other than "on" is that my load times went from 5 minutes to load the game to 30 seconds or less depending on where I'm loading into (fast travel to a new zone or just going into a house)

[EDIT] confirmed that the only thing that works correctly is vsync fast. My saved games won't load if I use either adaptive setting. I don't even need to run riva, and I have gsync off. This gets me about 48 FPS consistently, which is certainly playable if not perfect. I might look into a different monitor with a higher refresh, I dunno.
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 10:00 pm

sounds really weird but if it works it works
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 10:52 pm

It's amazing how this all works out, but I am extremely suspicious now that the monitor is bad. I should be able to get 144hz on this thing, but only have option for 24hz. I've reinstalled every driver imaginable but to no avail. Setting up RMA and replacing it!
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 10:57 pm

wow yea thats definitely not right 24 hz is really bad lol especially if its a 144 hz monitor. However, dont send it in just yet. what cable are you using on the monitor and do you use duel monitors or more? if you use the wrong cable it can limit your refresh rate to that of what the cable supports and if you use duel monitors this can cause issues if one of them is using a bad cable
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 11:06 pm

using stock Display Port cable that came with the monitor
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sat Dec 24, 2016 11:15 pm

I would try chaning the cable and using only 1 monitor and if its still stuck at 24hz then yea RMA it
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Sun Dec 25, 2016 3:35 am

I'll give the cable a shot I guess. Only using 1 monitor, so that's not an issue. Thanks for the feedback. Merry Christmas :)
Back to top Go down
View user profile
knight6254
Look ma no hands
Look ma no hands


Posts : 29
Points : 151
Reputation : 0
Join date : 2016-10-29

PostSubject: Re: [solved]failed to allocate memory   Sun Dec 25, 2016 5:09 pm

Np good luck with the pack Merry Christmas
Back to top Go down
View user profile
Spookeh70
I'm getting the hang of this
I'm getting the hang of this


Posts : 21
Points : 126
Reputation : 1
Join date : 2016-11-17

PostSubject: Re: [solved]failed to allocate memory   Mon Dec 26, 2016 10:20 pm

Figured it out! Talk about not-intuitive. The monitor didn't come set to default for 144. I had to manually trip the turbo option. Once I did that it set to 120. Then when I opened up Nvidia control panel, I was able to set it to 144. Yay!

Thanks again Rotten and everyone for the help. This can be considered solved: no fault of the pack - as usual, it was user error heheh :)
Back to top Go down
View user profile
 
[solved]failed to allocate memory
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Perfectly Modded :: Forum :: SPM 4.4-
Jump to:  

Free counters!