Perfectly Modded

Modding done right!
 
HomeHome  WebsiteWebsite  YouTubeYouTube  TwitchTwitch  CalendarCalendar  GalleryGallery  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 FNIS ERROR(9): Index was outside the bounds of the array

View previous topic View next topic Go down 
AuthorMessage
venomatix
New Face!
New Face!


Posts : 3
Points : 86
Reputation : 0
Join date : 2017-01-04

PostSubject: FNIS ERROR(9): Index was outside the bounds of the array   Wed Jan 04, 2017 5:27 pm

Hello guys,

after trying to solve this problem by myself for couple of days, I came to the conclusion that I dont know what else to do. I saw several Posts about it on the forums here, but not one was able to help me out.

My problem is, that everyone is stuck in the "T-Pose" in my game. So I researched a bit about it and found out that I needed to patch it with FNIS. I set everything up but it wont let me patch it, it always gives me the same error, the one I mentioned in the Title.

Here are the things I tryed out to fix it :

- set GenerateFNISforUsers as ADMIN
- .NET is the newest version
- Loadorder is exactly like here https://modwat.ch/u/RottenDub
- Reinstalling the Pack several times didnt help either
- Overwritten the FNIS Behavior in MO
- Created a new Mod with the overwritten files


Nothing helped me and everyone is still stuck in the T-Pose in my game. I would be thankful if someone would be able to help me out on it!

My Specs : 

CPU : Intel Core i5-4460 CPU @ 3.20GHz
RAM : 12gb
GPU : Nvidia Geforce GTX 760

Running on WIN10


I hope everyone have a great day!
Back to top Go down
View user profile
tolstyy
Dragon Slayer
Dragon Slayer


Posts : 138
Points : 457
Reputation : 11
Join date : 2016-06-03

PostSubject: Re: FNIS ERROR(9): Index was outside the bounds of the array   Wed Jan 04, 2017 6:48 pm

I had this problem only after disabling Dyndolod. To have everything ok do the following:

1. Install the licensed game (not steam) to X:/Skyrim

2. Install the pack to this location.

3. Run ModOrganizer and make sure no error messages shown up.

4. Play.
Back to top Go down
View user profile
venomatix
New Face!
New Face!


Posts : 3
Points : 86
Reputation : 0
Join date : 2017-01-04

PostSubject: Re: FNIS ERROR(9): Index was outside the bounds of the array   Wed Jan 04, 2017 6:56 pm

@tolstyy wrote:
I had this problem only after disabling Dyndolod. To have everything ok do the following:

1. Install the licensed game (not steam) to X:/Skyrim

2. Install the pack to this location.

3. Run ModOrganizer and make sure no error messages shown up.

4. Play.

I never disabled any mods from the pack :s. And I tried to reinstall it several times now, didnt help out :/.

Thank you for the post though!

E1: also the only Skyrim version I have is from steam. I did my best though to follow the instructions on this site to set everything up.

E2: I found out that FNIS also gives me the following message : >>Warning: AnimationList found in  "Animations\FNIS_PCEA2", but no corresponding Behavior file. Incomplete mod IGNORED.<<.
Back to top Go down
View user profile
RottenDub
Admin
Admin
avatar

Posts : 1474
Points : 2703
Reputation : 292
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: FNIS ERROR(9): Index was outside the bounds of the array   Thu Jan 05, 2017 4:48 am

Quote :
The FNIS "ERROR(9): Index was outside the bounds of the array" was caused by Unofficial Skyrim Legendary Edition Patch being in the wrong part of the load order. Almost at the bottom. Also had a few other minor loadorder conflicts, but moving the Unofficial Patch to the top solved everything for me. SPM seems to be working perfectly now and it looks gorgeous! Just hope I've got everything else is in the right loadorder.

I'll leave this here just in case somebody else runs in to the same.

__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
venomatix
New Face!
New Face!


Posts : 3
Points : 86
Reputation : 0
Join date : 2017-01-04

PostSubject: Re: FNIS ERROR(9): Index was outside the bounds of the array   Thu Jan 05, 2017 2:53 pm

@RottenDub wrote:
Quote :
The FNIS "ERROR(9): Index was outside the bounds of the array" was caused by Unofficial Skyrim Legendary Edition Patch being in the wrong part of the load order. Almost at the bottom. Also had a few other minor loadorder conflicts, but moving the Unofficial Patch to the top solved everything for me. SPM seems to be working perfectly now and it looks gorgeous! Just hope I've got everything else is in the right loadorder.

I'll leave this here just in case somebody else runs in to the same.
Hello,

thank you for the reply!

Unfortunately though, I already saw this post earlier and checked where my Unofficial Skyrim Legendary Edition Patch in the loadorder was. It was almost at the top the whole time, because like I mentioned before I did the exact loadorder like here on the page https://modwat.ch/u/RottenDub


EDIT: Ok, I think I found out where the Problem is. When I try to start FNIS through Modloader, it is not starting as ADMIN so it is not able to update. When I tried to start it from the MO Loader Folder everything was able to patch BUT I dont know where to put those files in. Can someone help?
Back to top Go down
View user profile
RottenDub
Admin
Admin
avatar

Posts : 1474
Points : 2703
Reputation : 292
Join date : 2015-08-06
Age : 30
Location : Where bad dreams begin

PostSubject: Re: FNIS ERROR(9): Index was outside the bounds of the array   Fri Jan 06, 2017 3:07 am

Just right click the .exe -> Proprieties -> compatibility -> run as admin -> apply. Run through MO.

__________________________
Back to top Go down
View user profile http://perfectlymodded.weebly.com/
 
FNIS ERROR(9): Index was outside the bounds of the array
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Perfectly Modded :: Forum :: SPM 4.4-
Jump to:  

Free counters!